Unable to get Local user Certificate

Hi,
We are trying to login electroneek studio but we are getting an error"Unable to get Local user Certificate".but orchestrator is working fine.Could someone help us.

Hi @Nikilesh,

This could happen if you have some certificate substitution in your network environment. It could be proxy or gateway. Or hackers.
I recommend you contact your network administrator to check your environment.
There’s an option to ignore this certificate check, but it is unsecure, so please consult your network admin first. https://knowledge.electroneek.com/agent-program-description/show-summary#ignore-https-certificate-verification

Hi Tim,
Could you please tell me What kind changes or certificates we need to do ?(we already checked in Internet explorer HTTP Check boxes ,we made all enable but still gets error"While doing login we are Facing Unable to get Local user certificate".

@Nikilesh,

  1. Right-click on Electroneek Robot icon in system tray
  2. Choose ‘Show summary’
  3. Go to ‘Settings’ tab
  4. Check the ‘Ignore HTTPS sertificate verification’.
  5. Try to login again

Please let me know if it helped.

Hi,
After choosing Show summary,I’m getting login page and one more tab is Proxy tab.In proxy tab,i have check box which is Use Proxy server.Even i enabled that check box,still its getting error Unable to get local user certificate.

Hi @Nikilesh,

Do you have any antivirus or firewall installed?
Would you please add Electroneek to their whitelist and try again?

Hi Tim,

What Electroneek URL we need to add to whitelist ?
please provide us details

Hi @Nikilesh,

This is URL list: https://knowledge.electroneek.com/platform-information/system-requirements#network-requirements

Please also add c:\Program Files\electroNeek\agent-js\electroNeek-agent.exe and c:\Program Files\electroNeek\devtool\ElectroNeek DevTool.exe

Hi Tim,

I saw those URl’s.But over network team is asking those URL’s are Static or dynamic.Please let us know as soon as possible.

Hi Tim,

I connected through VPN,then i’m not getting “unable to get local issuer certificate error”.But
after pressing Electroneek Agent login button,it freezes like that.Even i cant close electroneek agent and studio.i need to use Task manager to end those tasks.
Could you please help us.

Those urls are static

@Nikilesh, would you please update platform version.
We’ve added the ability to ignore certificate verification in 3.9
After you update just do this steps:

  1. Right-click on Electroneek Robot icon in system tray
  2. Choose ‘Show summary’
  3. Go to ‘Settings’ tab
  4. Check the ‘Ignore HTTPS sertificate verification’.
  5. Try to login again